bsd.default-versions.mk 4.76 KB
Newer Older
1
2
3
4
# $FreeBSD$
#
# MAINTAINER:	ports@FreeBSD.org
#
5
6
7
8
# Note: before committing to this file, contact portmgr to arrange for an
# experimental ports run.  Untested commits may be backed out at portmgr's
# discretion.
#
9
10
# Provide default versions for ports with multiple versions selectable
# by the user.
11
#
12
13
# Users who want to override these defaults can easily do so by defining
# DEFAULT_VERSIONS in their make.conf as follows:
14
#
15
#   DEFAULT_VERSIONS=	perl5=5.20 ruby=2.0
16
17
18
19

.if !defined(_INCLUDE_BSD_DEFAULT_VERSIONS_MK)
_INCLUDE_BSD_DEFAULT_VERSIONS_MK=	yes

20
21
LOCALBASE?=	/usr/local

flo's avatar
flo committed
22
.for lang in APACHE BDB COROSYNC EMACS FIREBIRD FORTRAN FPC GCC GHOSTSCRIPT \
23
	JAVA JULIA LAZARUS LINUX LLVM LUA MYSQL PERL5 PGSQL PHP PYTHON PYTHON2 \
24
	PYTHON3 RUBY RUST SAMBA SSL TCLTK VARNISH
25
.if defined(${lang}_DEFAULT)
26
ERROR+=	"The variable ${lang}_DEFAULT is set and it should only be defined through DEFAULT_VERSIONS+=${lang:tl}=${${lang}_DEFAULT} in /etc/make.conf"
27
28
29
30
.endif
#.undef ${lang}_DEFAULT
.endfor

31
32
.for lang in ${DEFAULT_VERSIONS}
_l=		${lang:C/=.*//g}
bapt's avatar
bapt committed
33
${_l:tu}_DEFAULT=	${lang:C/.*=//g}
34
35
.endfor

sunpoet's avatar
sunpoet committed
36
# Possible values: 2.4
37
APACHE_DEFAULT?=	2.4
38
39
# Possible values: 48, 5, 6
BDB_DEFAULT?=		5
flo's avatar
flo committed
40
41
# Possible values: 2, 3
COROSYNC_DEFAULT?=	2
jrm's avatar
jrm committed
42
43
# Possible_values: full canna nox devel_full devel_nox
#EMACS_DEFAULT?=	let the flavor be the default if not explicitly set
44
# Possible values: 2.5
45
FIREBIRD_DEFAULT?=	2.5
46
47
# Possible values: flang (experimental), gfortran
FORTRAN_DEFAULT?=	gfortran
acm's avatar
acm committed
48
# Possible values: 3.0.4
acm's avatar
acm committed
49
FPC_DEFAULT?=		3.0.4
50
# Possible values: 8, 9 (powerpcspe was dropped with GCC 9)
51
52
53
.if ${ARCH} == "powerpcspe"
GCC_DEFAULT?=		8
.else
54
GCC_DEFAULT?=		9
55
.endif
56
# Possible values: 7, 8, 9, agpl
57
GHOSTSCRIPT_DEFAULT?=	agpl
58
# Possible values: 7, 8, 11, 12, 13, 14, 15
59
JAVA_DEFAULT?=		8
60
61
# Possible values: 0.6, 0.7, 1.0, 1.1
JULIA_DEFAULT?=		1.0
acm's avatar
acm committed
62
# Possible values: 2.0.8
acm's avatar
acm committed
63
LAZARUS_DEFAULT?=	2.0.8
rene's avatar
rene committed
64
# Possible values: c7
65
LINUX_DEFAULT?=		c7
jbeich's avatar
jbeich committed
66
# Possible values: 60, 70, 80, 90, -devel (to be used when non-base compiler is required)
67
68
# Please give notice to the Graphics Team (x11@FreeBSD.org) in advance before 
# bumping the LLVM version.
jbeich's avatar
jbeich committed
69
LLVM_DEFAULT?=		90
70
# Possible values: 5.1, 5.2, 5.3
71
LUA_DEFAULT?=		5.2
72
# Possible values: 5.5, 5.6, 5.7, 8.0, 10.3m, 10.4m, 10.5m, 5.5p, 5.6p, 5.7p, 5.6w, 5.7w
ale's avatar
ale committed
73
MYSQL_DEFAULT?=		5.7
mat's avatar
mat committed
74
# Possible values: 5.28, 5.30, 5.32, devel
75
76
.if !exists(${LOCALBASE}/bin/perl) || (!defined(_PORTS_ENV_CHECK) && \
    defined(PACKAGE_BUILDING))
mat's avatar
mat committed
77
PERL5_DEFAULT?=		5.32
78
79
80
81
82
.elif !defined(PERL5_DEFAULT)
# There's no need to replace development versions, like "5.23" with "devel"
# because 1) nobody is supposed to use it outside of poudriere, and 2) it must
# be set manually in /etc/make.conf in the first place, and we're never getting
# in here.
83
.if !defined(_PERL5_FROM_BIN)
84
_PERL5_FROM_BIN!=	${LOCALBASE}/bin/perl -e 'printf "%vd\n", $$^V;'
85
86
.endif
_EXPORTED_VARS+=	_PERL5_FROM_BIN
87
88
PERL5_DEFAULT:=		${_PERL5_FROM_BIN:R}
.endif
rene's avatar
rene committed
89
# Possible values: 9.5, 9.6, 10, 11, 12
90
PGSQL_DEFAULT?=		12
sunpoet's avatar
sunpoet committed
91
# Possible values: 7.2, 7.3, 7.4
92
PHP_DEFAULT?=		7.4
93
# Possible values: 2.7, 3.6, 3.7, 3.8, 3.9
94
PYTHON_DEFAULT?=	3.7
95
# Possible values: 2.7
96
PYTHON2_DEFAULT?=	2.7
97
# Possible values: 3.6, 3.7, 3.8, 3.9
98
PYTHON3_DEFAULT?=	3.7
meta's avatar
meta committed
99
# Possible values: 2.5, 2.6, 2.7, 3.0
100
RUBY_DEFAULT?=		2.6
jbeich's avatar
jbeich committed
101
102
# Possible values: rust, rust-nightly
RUST_DEFAULT?=		rust
timur's avatar
timur committed
103
# Possible values: 4.10, 4.11, 4.12, 4.13
104
SAMBA_DEFAULT?=		4.10
105
# Possible values: base, openssl, libressl, libressl-devel
mat's avatar
mat committed
106
107
108
.if !defined(SSL_DEFAULT)
#	If no preference was set, check for an installed base version
#	but give an installed port preference over it.
109
.  if	!defined(SSL_DEFAULT) && \
mat's avatar
mat committed
110
111
112
113
114
	!exists(${DESTDIR}/${LOCALBASE}/lib/libcrypto.so) && \
	exists(${DESTDIR}/usr/include/openssl/opensslv.h)
SSL_DEFAULT=	base
.  else
.    if exists(${DESTDIR}/${LOCALBASE}/lib/libcrypto.so)
115
.      if defined(PKG_BIN)
mat's avatar
mat committed
116
# find installed port and use it for dependency
117
118
.        if !defined(OPENSSL_INSTALLED)
.          if defined(DESTDIR)
mat's avatar
mat committed
119
PKGARGS=	-c ${DESTDIR}
120
.          else
mat's avatar
mat committed
121
PKGARGS=
122
.          endif
mat's avatar
mat committed
123
OPENSSL_INSTALLED!=	${PKG_BIN} ${PKGARGS} which -qo ${LOCALBASE}/lib/libcrypto.so || :
124
125
.        endif
.        if defined(OPENSSL_INSTALLED) && !empty(OPENSSL_INSTALLED)
mat's avatar
mat committed
126
SSL_DEFAULT:=		${OPENSSL_INSTALLED:T}
mat's avatar
mat committed
127
WARNING+=	"You have ${OPENSSL_INSTALLED} installed but do not have DEFAULT_VERSIONS+=ssl=${SSL_DEFAULT} set in your make.conf"
128
129
130
131
132
133
134
.        endif
.      else
check-makevars::
	@${ECHO_MSG} "You have a ${LOCALBASE}/lib/libcrypto.so file installed, but the framework is unable"
	@${ECHO_MSG} "to determine what port it comes from."
	@${ECHO_MSG} "Add DEFAULT_VERSIONS+=ssl=<openssl package name> to your /etc/make.conf and try again."
	@${FALSE}
mat's avatar
mat committed
135
136
137
138
139
140
.      endif
.    endif
.  endif
# Make sure we have a default in the end
SSL_DEFAULT?=	base
.endif
gahr's avatar
gahr committed
141
# Possible values: 8.5, 8.6, 8.7
142
TCLTK_DEFAULT?=		8.6
143

feld's avatar
feld committed
144
# Possible values: 4, 6
feld's avatar
feld committed
145
146
VARNISH_DEFAULT?=	4

147
.endif