Commit 3f096400 authored by rene's avatar rene
Browse files

Follow up on graphics/py-pillow6 port removal in r559976

The graphics/py-pillow6 port was removed in r559976 as it was for
Python 2.7 only and no longer referenced in the default cases.
However it was still defined in Mk/Uses/python.mk in PY_PILLOW,
leaving a dangling reference.

Remove it from Mk/Uses/python.mk, leaving only the Python 3
version of that port, graphics/py-pillow, defined and bump the
minimal verion of Python to 3.6 for affected ports.
parent 20ff20e4
......@@ -644,7 +644,6 @@ PYNUMPY= ${PYTHON_PKGNAMEPREFIX}numpy>=1.16,1<1.20,1:math/py-numpy@${PY_FLAVOR}
# Common Python modules that can be needed but only for some versions of Python.
.if ${PYTHON_REL} < 3500
PY_PILLOW= ${PYTHON_PKGNAMEPREFIX}pillow6>=6.0.0:graphics/py-pillow6@${PY_FLAVOR}
PY_PYGMENTS= ${PYTHON_PKGNAMEPREFIX}pygments-25>=2.5.1<3:textproc/py-pygments-25@${PY_FLAVOR}
PY_SPHINX= ${PYTHON_PKGNAMEPREFIX}sphinx18>=0,1:textproc/py-sphinx18@${PY_FLAVOR}
PY_TYPING= ${PYTHON_PKGNAMEPREFIX}typing>=3.7.4.1:devel/py-typing@${PY_FLAVOR}
......
......@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>0:devel/py-lxml@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyusb>0:devel/py-pyusb@${PY_FLAVOR} \
${PY_PILLOW}
USES= python:run,-3.7 shebangfix zip
USES= python:run,3.6-3.7 shebangfix zip
SHEBANG_FILES= *.py
DESKTOP_ENTRIES= "K40 Whisperer" \
......
......@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL@${PY_FLAVOR} \
${LOCALBASE}/share/${PORTNAME}/default.ttf:games/fretsonfire-data
USES= dos2unix python
USES= dos2unix python:3.6+
DOS2UNIX_FILES= *.txt
NO_BUILD= yes
NO_ARCH= yes
......
......@@ -57,7 +57,7 @@ LICENSE_DISTFILES_ULG= ${CARDSETDIST}
LICENSE_FILE_GPLv2+ = ${WRKDIR}/${CARDSETDIR}/cardset-1567/COPYRIGHT
LICENSE_DISTFILES_GPLv2+ = ${CARDSETDIST}
USES= python shebangfix tar:xz
USES= python:3.6+ shebangfix tar:xz
USE_PYTHON= distutils noflavors autoplist
SHEBANG_FILES= data/themes/clearlooks/convert_imgs.sh
NO_ARCH= yes
......
......@@ -40,7 +40,7 @@ NLS_USES= gettext
X11_USES= display:test
USES= autoreconf bison compiler:c11 cpe gmake iconv libtool \
pathfix perl5 python shebangfix tar:bzip2
pathfix perl5 python:3.6+ shebangfix tar:bzip2
USE_PERL5= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
......
......@@ -41,7 +41,7 @@ NLS_USES= gettext
X11_USES= display:test
USES= autoreconf bison compiler:c11 cpe gmake iconv libtool \
pathfix perl5 python shebangfix tar:bzip2
pathfix perl5 python:3.6+ shebangfix tar:bzip2
USE_PERL5= build
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
......
......@@ -16,7 +16,7 @@ RUN_DEPENDS= ${PY_PILLOW}
NO_BUILD= yes
USES= python:run shebangfix tar:tgz
USES= python:run,3.6+ shebangfix tar:tgz
SHEBANG_FILES= xs.py
PLIST_FILES= bin/xs
......
......@@ -15,7 +15,7 @@ RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}protobuf>=3.6.0:devel/py-protobuf@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR}
USES= python
USES= python:3.6+
USE_GITHUB= yes
GH_ACCOUNT= microsoft
GH_PROJECT= MMdnn
......
......@@ -21,7 +21,7 @@ RUN_DEPENDS= cups-filters>=0:print/cups-filters \
CONFLICTS_INSTALL= hpijs-[0-9]*
INSTALL_TARGET= install-strip
USES= dos2unix jpeg libtool pkgconfig python shebangfix
USES= dos2unix jpeg libtool pkgconfig python:3.6+ shebangfix
USE_LDCONFIG= yes
SHEBANG_GLOB= *.py hpps pstotiff
DOS2UNIX_FILES= scan/sane/orblite.c
......
......@@ -19,7 +19,7 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libfreetype.so:print/freetype2 \
libmaeparser.so:science/maeparser
USES= bison:build cmake compiler:c++11-lang eigen:3 python
USES= bison:build cmake compiler:c++11-lang eigen:3 python:3.6+
USE_GITHUB= yes
GH_TUPLE= rareylab:RingDecomposerLib:v1.1.3_rdkit:RingDecomposerLib/External/RingFamilies/RingDecomposerLib
USE_LDCONFIG= yes
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment