Commit 77aa4366 authored by kwm's avatar kwm
Browse files

* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which

  are the latest stable releases.
* Update vala to the newest stable release 0.18.1, also update a few ports
  in the gtk/gnome stack.
* The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles.
* Remove pkg-config run depends from glib20 and freetype2. This doesn't
  eliminate pkg-config run dependency completely, a second phase is needed
  and is planned.
* Support for .:run. and .:build. for USE_GNOME components was added.
  Currently only libxml2 and libxslt support this mechanism.
* Updates of the telepathy stack and empathy.
* Trim makefile headers, convert ports to new options, trim off library
  versions for some ports.
* Fix other ports so they build with the new glib version.

Thanks to miwi and crees for helping out with some exp-runs.
Approved by:	portmgr (miwi & bapt)
Obtained from:	gnome team repo
parent 0fdeab22
#-*- tab-width: 4; -*-
#-*- mode: Fundamental; tab-width: 4; -*-
# ex:ts=4
#
# $FreeBSD$
# $NetBSD: $
# $MCom: ports/Mk/bsd.gnome.mk,v 1.549 2011/06/10 22:16:59 mezz Exp $
# $MCom: ports/Mk/bsd.gnome.mk,v 1.574 2012/12/18 12:15:14 kwm Exp $
#
# Please view me with 4 column tabs!
......@@ -78,7 +78,7 @@ _USE_GNOME_ALL+= bonobo gconf gdkpixbuf glib12 \
libgda libghttp libglade libxml imlib oaf orbit
# GNOME 2 components
_USE_GNOME_ALL+= atk atspi desktopfileutils eel2 evolutiondataserver gal2 \
_USE_GNOME_ALL+= atk atspi cairo desktopfileutils eel2 evolutiondataserver gal2 \
gdkpixbuf2 gconf2 _glib20 glib20 gnomecontrolcenter2 gnomedesktop \
gnomedesktopsharp20 gnomedocutils gnomemenus gnomepanel gnomesharp20 \
gnomespeech gnomevfs2 gtk-update-icon-cache gtk20 gtkhtml3 gtksharp10 \
......@@ -93,11 +93,18 @@ _USE_GNOME_ALL+= atk atspi desktopfileutils eel2 evolutiondataserver gal2 \
# GNOME 3 components
_USE_GNOME_ALL+= dconf gtk30
# C++ bindings
_USE_GNOME_ALL+=atkmm cairomm gconfmm gconfmm26 glibmm gtkmm20 gtkmm24 \
gtkmm30 libgdamm \
libgtksourceviewmm libxml++ libxml++26 libsigc++12 libsigc++20 \
pangomm
GNOME_MAKEFILEIN?= Makefile.in
SCROLLKEEPER_DIR= /var/db/rarian
gnomehack_PRE_PATCH= ${FIND} ${WRKSRC} -name "${GNOME_MAKEFILEIN}*" -type f | ${XARGS} ${REINPLACE_CMD} -e \
's|[(]libdir[)]/locale|(prefix)/share/locale|g ; \
s|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
s|{libdir}/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
s|[(]datadir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
s|[(]prefix[)]/lib/pkgconfig|(prefix)/libdata/pkgconfig|g ; \
s|[$$][(]localstatedir[)]/scrollkeeper|${SCROLLKEEPER_DIR}|g ; \
......@@ -129,6 +136,67 @@ gnomeprefix_CONFIGURE_ARGS=--localstatedir=${GNOME_LOCALSTATEDIR} \
--with-gconf-source=${GCONF_CONFIG_SOURCE}
gnomeprefix_USE_GNOME_IMPL=gnomehier
atkmm_DETECT= ${LOCALBASE}/libdata/pkgconfig/atkmm-1.6.pc
atkmm_LIB_DEPENDS= atkmm-1.6:${PORTSDIR}/accessibility/atkmm
atkmm_USE_GNOME_IMPL= glibmm atk
libxml++_DETECT= ${LOCALBASE}/libdata/pkgconfig/libxml++-1.0.pc
libxml++_LIB_DEPENDS= xml++-1.0:${PORTSDIR}/textproc/libxml++
libxml++_USE_GNOME_IMPL= libxml2
libxml++26_DETECT= ${LOCALBASE}/libdata/pkgconfig/libxml++-2.6.pc
libxml++26_LIB_DEPENDS= xml++-2.6:${PORTSDIR}/textproc/libxml++26
libxml++26_USE_GNOME_IMPL= glibmm libxml2
cairo_DETECT= ${LOCALBASE}/libdata/pkgconfig/cairo.pc
cairo_LIB_DEPENDS= cairo:${PORTSDIR}/graphics/cairo
cairomm_DETECT= ${LOCALBASE}/libdata/pkgconfig/cairomm-1.0.pc
cairomm_LIB_DEPENDS= cairomm-1.0:${PORTSDIR}/graphics/cairomm
cairomm_USE_GNOME_IMPL= cairo libxml++26
gconfmm_DETECT= ${LOCALBASE}/libdata/pkgconfig/gconfmm-2.0.pc
gconfmm_LIB_DEPENDS= gconfmm-2.0:${PORTSDIR}/devel/gconfmm
gconfmm_USE_GNOME_IMPL= gtkmm20 gconf2
gconfmm26_DETECT= ${LOCALBASE}/libdata/pkgconfig/gconfmm-2.6.pc
gconfmm26_LIB_DEPENDS= gconfmm-2.6:${PORTSDIR}/devel/gconfmm26
gconfmm26_USE_GNOME_IMPL= glibmm gconf2
glibmm_DETECT= ${LOCALBASE}/libdata/pkgconfig/glibmm-2.4.pc
glibmm_LIB_DEPENDS= glibmm-2.4:${PORTSDIR}/devel/glibmm
glibmm_USE_GNOME_IMPL= libsigc++20 glib20
gtkmm20_DETECT= ${LOCALBASE}/libdata/pkgconfig/gtkmm-2.0.pc
gtkmm20_LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtkmm20
gtkmm20_USE_GNOME_IMPL= libsigc++12 gtk20
gtkmm24_DETECT= ${LOCALBASE}/libdata/pkgconfig/gtkmm-2.4.pc
gtkmm24_LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24
gtkmm24_USE_GNOME_IMPL= glibmm cairomm atkmm pangomm gtk20
gtkmm30_DETECT= ${LOCALBASE}/libdata/pkgconfig/gtkmm-3.0.pc
gtkmm30_LIB_DEPENDS= gtkmm-3.0:${PORTSDIR}/x11-toolkits/gtkmm30
gtkmm30_USE_GNOME_IMPL= glibmm cairomm atkmm pangomm gtk30
libgdamm_DETECT= ${LOCALBASE}/libdata/pkgconfig/libgdamm-4.0.pc
libgdamm_LIB_DEPENDS= gdamm-4.0:${PORTSDIR}/databases/libgdamm
libgdamm_USE_GNOME_IMPL=libgda4 glibmm
libgtksourceviewmm_DETECT= ${LOCALBASE}/libdata/pkgconfig/gtksourceviewmm-2.0.pc
libgtksourceviewmm_LIB_DEPENDS= gtksourceviewmm-2.0:${PORTSDIR}/x11-toolkits/libgtksourceviewmm
libgtksourceviewmm_USE_GNOME_IMPL= gtksourceview2 gtkmm24
libsigc++12_DETECT= ${LOCALBASE}/libdata/pkgconfig/sigc++-1.2.pc
libsigc++12_LIB_DEPENDS= sigc-1.2:${PORTSDIR}/devel/libsigc++12
libsigc++20_DETECT= ${LOCALBASE}/libdata/pkgconfig/sigc++-2.0.pc
libsigc++20_LIB_DEPENDS= sigc-2.0:${PORTSDIR}/devel/libsigc++20
pangomm_DETECT= ${LOCALBASE}/libdata/pkgconfig/pangomm-1.4.pc
pangomm_LIB_DEPENDS= pangomm-1.4:${PORTSDIR}/x11-toolkits/pangomm
pangomm_USE_GNOME_IMPL= pango glibmm cairomm
ESD_CONFIG?= ${LOCALBASE}/bin/esd-config
esound_LIB_DEPENDS= esd.2:${PORTSDIR}/audio/esound
esound_CONFIGURE_ENV= ESD_CONFIG="${ESD_CONFIG}"
......@@ -143,7 +211,6 @@ glib12_LIB_DEPENDS= glib-12.3:${PORTSDIR}/devel/glib12
glib12_CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}"
glib12_MAKE_ENV= GLIB_CONFIG="${GLIB_CONFIG}"
glib12_DETECT= ${GLIB_CONFIG}
glib12_USE_GNOME_IMPL= pkgconfig
GTK_CONFIG?= ${LOCALBASE}/bin/gtk12-config
gtk12_LIB_DEPENDS= gtk-12.2:${PORTSDIR}/x11-toolkits/gtk12
......@@ -246,9 +313,9 @@ libglade_MAKE_ENV= LIBGLADE_CONFIG="${LIBGLADE_CONFIG}"
libglade_DETECT= ${LIBGLADE_CONFIG}
libglade_USE_GNOME_IMPL=gnomedb
_glib20_LIB_DEPENDS= glib-2.0.0:${PORTSDIR}/devel/glib20
_glib20_LIB_DEPENDS= glib-2.0:${PORTSDIR}/devel/glib20 \
pcre:${PORTSDIR}/devel/pcre
_glib20_DETECT= ${LOCALBASE}/libdata/pkgconfig/glib-2.0.pc
_glib20_USE_GNOME_IMPL= pkgconfig
glib20_RUN_DEPENDS= ${LOCALBASE}/lib/gio/modules/libgiofam.so:${PORTSDIR}/devel/gio-fam-backend
glib20_DETECT= ${LOCALBASE}/lib/gio/modules/libgiofam.so
......@@ -301,11 +368,14 @@ libglade2_LIB_DEPENDS= glade-2.0.0:${PORTSDIR}/devel/libglade2
libglade2_DETECT= ${LOCALBASE}/libdata/pkgconfig/libglade-2.0.pc
libglade2_USE_GNOME_IMPL=libxml2 gtk20
libxml2_BUILD_DEPENDS= xml2-config:${PORTSDIR}/textproc/libxml2
libxml2_LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
libxml2_RUN_DEPENDS= xml2-config:${PORTSDIR}/textproc/libxml2
libxml2_DETECT= ${LOCALBASE}/libdata/pkgconfig/libxml-2.0.pc
libxml2_USE_GNOME_IMPL= pkgconfig
libxslt_BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
libxslt_LIB_DEPENDS= xslt.2:${PORTSDIR}/textproc/libxslt
libxslt_RUN_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
libxslt_DETECT= ${LOCALBASE}/libdata/pkgconfig/libxslt.pc
libxslt_USE_GNOME_IMPL= libxml2
......@@ -327,7 +397,6 @@ libgnomecanvas_USE_GNOME_IMPL= libglade2 libartlgpl2
libartlgpl2_LIB_DEPENDS= art_lgpl_2.5:${PORTSDIR}/graphics/libart_lgpl
libartlgpl2_DETECT= ${LOCALBASE}/libdata/pkgconfig/libart-2.0.pc
libartlgpl2_USE_GNOME_IMPL= pkgconfig
libgnomeprint_LIB_DEPENDS= gnomeprint-2-2.0:${PORTSDIR}/print/libgnomeprint
libgnomeprint_DETECT= ${LOCALBASE}/libdata/pkgconfig/libgnomeprint-2.2.pc
......@@ -364,16 +433,17 @@ libgtkhtml_USE_GNOME_IMPL=libxslt gnomevfs2
gnomedesktop_LIB_DEPENDS= gnome-desktop-2.17:${PORTSDIR}/x11/gnome-desktop
gnomedesktop_DETECT= ${LOCALBASE}/libdata/pkgconfig/gnome-desktop-2.0.pc
gnomedesktop_USE_GNOME_IMPL= gconf2 gnomedocutils pygtk2
gnomedesktop_GNOME_DESKTOP_VERSION=2
gnomedesktopsharp20_DETECT= ${LOCALBASE}/libdata/pkgconfig/gnome-desktop-sharp-2.0.pc
gnomedesktopsharp20_BUILD_DEPENDS= ${gnomedesktopsharp20_DETECT}:${PORTSDIR}/x11-toolkits/gnome-desktop-sharp20
gnomedesktopsharp20_RUN_DEPENDS= ${gnomedesktopsharp20_DETECT}:${PORTSDIR}/x11-toolkits/gnome-desktop-sharp20
gnomedesktopsharp20_USE_GNOME_IMPL= gnomesharp20 gnomepanel gtkhtml3 librsvg2 vte libgnomeprintui gtksourceview2 gnomepanel libwnck nautiluscdburner
gnomedesktopsharp20_GNOME_DESKTOP_VERSION=2
libwnck_LIB_DEPENDS= wnck-1.22:${PORTSDIR}/x11-toolkits/libwnck
libwnck_DETECT= ${LOCALBASE}/libdata/pkgconfig/libwnck-1.0.pc
libwnck_USE_GNOME_IMPL= gtk20
libwnck_GNOME_DESKTOP_VERSION=2
vte_LIB_DEPENDS= vte.9:${PORTSDIR}/x11-toolkits/vte
vte_DETECT= ${LOCALBASE}/libdata/pkgconfig/vte.pc
......@@ -397,13 +467,14 @@ gnomepanel_USE_GNOME_IMPL=gnomedesktop libwnck gnomemenus gnomedocutils librsvg2
gnomepanel_GNOME_DESKTOP_VERSION=2
nautilus2_LIB_DEPENDS= nautilus-extension.1:${PORTSDIR}/x11-fm/nautilus
nautilus2_DETECT= ${LOCALBASE}/libdata/pkgconfig/libnautilus-extension.pc
nautilus2_DETECT= ${LOCALBASE}/share/gir-1.0/Nautilus-2.0.gir
nautilus2_USE_GNOME_IMPL=librsvg2 gnomedesktop desktopfileutils gvfs
nautilus2_GNOME_DESKTOP_VERSION=2
metacity_LIB_DEPENDS= metacity-private.0:${PORTSDIR}/x11-wm/metacity
metacity_DETECT= ${LOCALBASE}/libdata/pkgconfig/libmetacity-private.pc
metacity_USE_GNOME_IMPL=gconf2
metacity_GNOME_DESKTOP_VERSION=2
gal2_LIB_DEPENDS= gal-2.4.0:${PORTSDIR}/x11-toolkits/gal2
gal2_DETECT= ${LOCALBASE}/libdata/pkgconfig/gal-2.4.pc
......@@ -412,6 +483,7 @@ gal2_USE_GNOME_IMPL=gnomeui libgnomeprintui
gnomecontrolcenter2_LIB_DEPENDS=gnome-window-settings.1:${PORTSDIR}/sysutils/gnome-control-center
gnomecontrolcenter2_DETECT=${LOCALBASE}/libdata/pkgconfig/gnome-window-settings-2.0.pc
gnomecontrolcenter2_USE_GNOME_IMPL=metacity gnomemenus desktopfileutils libgnomekbd gnomedesktop librsvg2
gnomecontrolcenter2_GNOME_DESKTOP_VERSION=2
libgda2_LIB_DEPENDS= gda-2.3:${PORTSDIR}/databases/libgda2
libgda2_DETECT= ${LOCALBASE}/libdata/pkgconfig/libgda.pc
......@@ -485,6 +557,7 @@ gnomespeech_USE_GNOME_IMPL=libbonobo
evolutiondataserver_LIB_DEPENDS=edataserverui-1.2.11:${PORTSDIR}/databases/evolution-data-server
evolutiondataserver_DETECT= ${LOCALBASE}/libdata/pkgconfig/evolution-data-server-1.2.pc
evolutiondataserver_USE_GNOME_IMPL=gconf2 libxml2
evolutiondataserver_GNOME_DESKTOP_VERSION=2
desktopfileutils_BUILD_DEPENDS=update-desktop-database:${PORTSDIR}/devel/desktop-file-utils
desktopfileutils_RUN_DEPENDS=update-desktop-database:${PORTSDIR}/devel/desktop-file-utils
......@@ -494,10 +567,13 @@ desktopfileutils_USE_GNOME_IMPL=glib20
nautiluscdburner_LIB_DEPENDS=nautilus-burn.4:${PORTSDIR}/sysutils/nautilus-cd-burner
nautiluscdburner_DETECT= ${LOCALBASE}/libdata/pkgconfig/libnautilus-burn.pc
nautiluscdburner_USE_GNOME_IMPL=nautilus2 desktopfileutils
nautiluscdburner_GNOME_DESKTOP_VERSION=2
gnomemenus_LIB_DEPENDS= gnome-menu.2:${PORTSDIR}/x11/gnome-menus
gnomemenus_BUILD_DEPENDS= gnome-menus<=2.39.0:${PORTSDIR}/x11/gnome-menus
gnomemenus_RUN_DEPENDS= gnome-menus<=2.39.0:${PORTSDIR}/x11/gnome-menus
gnomemenus_DETECT= ${LOCALBASE}/libdata/pkgconfig/libgnome-menu.pc
gnomemenus_USE_GNOME_IMPL= glib20
gnomemenus_GNOME_DESKTOP_VERSION=2
pygnomeextras_DETECT= ${LOCALBASE}/libdata/pkgconfig/gnome-python-extras-2.0.pc
pygnomeextras_BUILD_DEPENDS= ${pygnomeextras_DETECT}:${PORTSDIR}/x11-toolkits/py-gnome-extras
......@@ -513,6 +589,7 @@ pygnomedesktop_DETECT= ${LOCALBASE}/libdata/pkgconfig/gnome-python-desktop-2.0.
pygnomedesktop_BUILD_DEPENDS= ${pygnomedesktop_DETECT}:${PORTSDIR}/x11-toolkits/py-gnome-desktop
pygnomedesktop_RUN_DEPENDS= ${pygnomedesktop_DETECT}:${PORTSDIR}/x11-toolkits/py-gnome-desktop
pygnomedesktop_USE_GNOME_IMPL=pygnome2 libgnomeprintui gtksourceview gnomepanel libwnck nautilus2 metacity
pygnomedesktop_GNOME_DESKTOP_VERSION=2
gtksharp10_DETECT= ${LOCALBASE}/libdata/pkgconfig/gtk-sharp.pc
gtksharp10_BUILD_DEPENDS= ${gtksharp10_DETECT}:${PORTSDIR}/x11-toolkits/gtk-sharp10
......@@ -529,9 +606,10 @@ gnomesharp20_BUILD_DEPENDS= ${gnomesharp20_DETECT}:${PORTSDIR}/x11-toolkits/gnom
gnomesharp20_RUN_DEPENDS= ${gnomesharp20_DETECT}:${PORTSDIR}/x11-toolkits/gnome-sharp20
gnomesharp20_USE_GNOME_IMPL= gnomepanel gtkhtml3 gtksharp20 librsvg2 vte
libgnomekbd_DETECT= ${LOCALBASE}/libdata/pkgconfig/libgnomekbd.pc
libgnomekbd_DETECT= ${LOCALBASE}/libdata/pkgconfig/libgnomekbd.pc
libgnomekbd_LIB_DEPENDS= gnomekbd.4:${PORTSDIR}/x11/libgnomekbd
libgnomekbd_USE_GNOME_IMPL= gconf2
libgnomekbd_GNOME_DESKTOP_VERSION=2
pygtksourceview_DETECT= ${LOCALBASE}/libdata/pkgconfig/pygtksourceview-2.0.pc
pygtksourceview_BUILD_DEPENDS= ${pygtksourceview_DETECT}:${PORTSDIR}/x11-toolkits/py-gtksourceview
......@@ -734,34 +812,45 @@ USE_CSTD= gnu89
GNOME_PRE_PATCH+= ${lthacks_PRE_PATCH}
CONFIGURE_ENV+= ${lthacks_CONFIGURE_ENV}
. endif
. for component in ${_USE_GNOME_ALL}
. if ${_USE_GNOME:M${component}}!=""
. for component in ${_USE_GNOME:O:u}
. if defined(${component}_PATCH_DEPENDS)
PATCH_DEPENDS+= ${${component}_PATCH_DEPENDS}
FETCH_DEPENDS+= ${${component}_FETCH_DEPENDS}
EXTRACT_DEPENDS+=${${component}_EXTRACT_DEPENDS}
. endif
. if defined(${component}_DETECT)
. if ${USE_GNOME:M${component}\:build}!=""
BUILD_DEPENDS+= ${${component}_BUILD_DEPENDS}
. if defined(MARCUSCOM_CVS)
. if !defined(NODEPENDS)
LIB_DEPENDS+= ${${component}_LIB_DEPENDS}
. elif ${USE_GNOME:M${component}\:run}!=""
RUN_DEPENDS+= ${${component}_RUN_DEPENDS}
. endif
. else
. else
. if defined(${component}_LIB_DEPENDS)
LIB_DEPENDS+= ${${component}_LIB_DEPENDS}
. else
BUILD_DEPENDS+= ${${component}_BUILD_DEPENDS}
RUN_DEPENDS+= ${${component}_RUN_DEPENDS}
. endif
. endif
. endif
. if defined(${component}_CONFIGURE_ARGS)
CONFIGURE_ARGS+=${${component}_CONFIGURE_ARGS}
. endif
. if defined(${component}_CONFIGURE_ENV)
CONFIGURE_ENV+= ${${component}_CONFIGURE_ENV}
. endif
. if defined(${component}_MAKE_ENV)
MAKE_ENV+= ${${component}_MAKE_ENV}
. endif
. if !defined(CONFIGURE_TARGET) && defined(${component}_CONFIGURE_TARGET)
. if !defined(CONFIGURE_TARGET) && defined(${component}_CONFIGURE_TARGET)
CONFIGURE_TARGET= ${${component}_CONFIGURE_TARGET}
. endif
. endif
. if defined(${component}_PRE_PATCH)
. if defined(${component}_PRE_PATCH)
GNOME_PRE_PATCH+= ; ${${component}_PRE_PATCH}
. endif
. endif
. endfor
.endif
......@@ -835,9 +924,9 @@ gnome-post-install:
${ECHO_CMD} "share/glib-2.0/schemas/$${i}" >> ${TMPPLIST}; \
done
@${ECHO_CMD} "@exec glib-compile-schemas %D/share/glib-2.0/schemas > /dev/null || /usr/bin/true" \
>> ${TMPPLIST}; \
${ECHO_CMD} "@unexec glib-compile-schemas --uninstall %D/share/glib-2.0/schemas > /dev/null || /usr/bin/true" \
>> ${TMPPLIST};
>> ${TMPPLIST}; \
${ECHO_CMD} "@unexec glib-compile-schemas %D/share/glib-2.0/schemas > /dev/null || /usr/bin/true" \
>> ${TMPPLIST};
.endif
. if defined(INSTALLS_OMF)
......
......@@ -5,6 +5,22 @@ they are unavoidable.
You should get into the habit of checking this file for changes each time
you update your ports collection, before attempting any port upgrades.
20130308:
AFFECTS: users of net-im/folks and devel/libgee
AUTHOR: kwm@FreeBSD.org
folks and libgee have been repocopied net-im/folks04 and devel/libgee06
respectively. Please do the following according to package manager used.
# portmaster -o devel/libgee06 devel/libgee
# portmaster -o net-im/folks04 net-im/folks
or
# portupgrade -fo devel/libgee06 devel/libgee
# portupgrade -fo net-im/folks04 net-im/folks
or
# pkg set -o devel/libgee:devel/libgee06
# pkg set -o net-im/folks:net-im/folks04
20130307:
AFFECTS: users of textproc/elasticsearch
AUTHOR: tj@FreeBSD.org
......
......@@ -21,4 +21,7 @@ GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
post-patch:
@${REINPLACE_CMD} -e 's|glib/.*\.h>|glib.h>|g' ${WRKSRC}/src/eventlog.h
.include <bsd.port.mk>
# New ports collection makefile for: at-spi
# Date Created: 12 April 2002
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/accessibility/at-spi2-atk/Makefile,v 1.16 2010/11/16 11:53:13 kwm Exp $
#
# $MCom: ports/accessibility/at-spi2-atk/Makefile,v 1.38 2012/12/16 22:36:25 kwm Exp $
PORTNAME= at-spi2-atk
PORTVERSION= 0.4.1
PORTREVISION= 1
PORTVERSION= 2.6.2
CATEGORIES= accessibility x11-toolkits
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Assisted Technology Provider module for GTK+
LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
RUN_DEPENDS= ${LOCALBASE}/libexec/at-spi2-registryd:${PORTSDIR}/accessibility/at-spi2-core
LICENSE= LGPL21
LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING
USE_BZIP2= yes
USE_GETTEXT= yes
BUILD_DEPENDS= at-spi2-core>=2.1.4:${PORTSDIR}/accessibility/at-spi2-core
LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
RUN_DEPENDS= at-spi2-core>=2.1.4:${PORTSDIR}/accessibility/at-spi2-core
CONFLICTS= at-spi-1.[0-9]*
PORTSCOUT= limitw:1,even
USE_XZ= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomehier intlhack gconf2 libxml2
USE_GNOME= gnomehack gnomehier intlhack glib20 atk
USE_PKGCONFIG= build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
GCONF_SCHEMAS= at-spi2.schemas
CONFIGURE_ARGS= --enable-p2p
GLIB_SCHEMAS= org.a11y.atspi.gschema.xml
.include <bsd.port.mk>
SHA256 (gnome2/at-spi2-atk-0.4.1.tar.bz2) = ad885b257f9e12bc1cfb0f21bd1075c00bdedca3f66d01b57401ecb12c9f411c
SIZE (gnome2/at-spi2-atk-0.4.1.tar.bz2) = 337286
SHA256 (gnome3/at-spi2-atk-2.6.2.tar.xz) = 496c8432e8ab82735145f9af5d45209e9b708bf3c94e527ee091d08641a9bcfa
SIZE (gnome3/at-spi2-atk-2.6.2.tar.xz) = 274748
--- atk-adaptor/accessible-cache.c.orig 2012-11-21 23:46:32.000000000 +0000
+++ atk-adaptor/accessible-cache.c 2012-11-21 23:47:06.000000000 +0000
@@ -362,7 +362,7 @@
if (!child)
{
g_static_rec_mutex_unlock (&cache_mutex);
- return;
+ return FALSE;
}
g_object_ref (child);
lib/gtk-2.0/modules/at-spi-dbus/modules/libatk-bridge.a
lib/gtk-2.0/modules/at-spi-dbus/modules/libatk-bridge.la
lib/gtk-2.0/modules/at-spi-dbus/modules/libatk-bridge.so
lib/gtk-3.0/modules/at-spi-dbus/modules/libatk-bridge.a
lib/gtk-3.0/modules/at-spi-dbus/modules/libatk-bridge.la
lib/gtk-3.0/modules/at-spi-dbus/modules/libatk-bridge.so
share/gnome/autostart/atk-bridge.desktop
share/locale/ar/LC_MESSAGES/at-spi2-atk.mo
share/locale/ast/LC_MESSAGES/at-spi2-atk.mo
share/locale/bg/LC_MESSAGES/at-spi2-atk.mo
share/locale/bn/LC_MESSAGES/at-spi2-atk.mo
share/locale/ca/LC_MESSAGES/at-spi2-atk.mo
share/locale/cs/LC_MESSAGES/at-spi2-atk.mo
share/locale/cy/LC_MESSAGES/at-spi2-atk.mo
share/locale/de/LC_MESSAGES/at-spi2-atk.mo
share/locale/el/LC_MESSAGES/at-spi2-atk.mo
share/locale/en@shaw/LC_MESSAGES/at-spi2-atk.mo
share/locale/en_GB/LC_MESSAGES/at-spi2-atk.mo
share/locale/es/LC_MESSAGES/at-spi2-atk.mo
share/locale/et/LC_MESSAGES/at-spi2-atk.mo
share/locale/eu/LC_MESSAGES/at-spi2-atk.mo
share/locale/fi/LC_MESSAGES/at-spi2-atk.mo
share/locale/fr/LC_MESSAGES/at-spi2-atk.mo
share/locale/gl/LC_MESSAGES/at-spi2-atk.mo
share/locale/he/LC_MESSAGES/at-spi2-atk.mo
share/locale/hu/LC_MESSAGES/at-spi2-atk.mo
share/locale/it/LC_MESSAGES/at-spi2-atk.mo
share/locale/ko/LC_MESSAGES/at-spi2-atk.mo
share/locale/lt/LC_MESSAGES/at-spi2-atk.mo
share/locale/nb/LC_MESSAGES/at-spi2-atk.mo
share/locale/nl/LC_MESSAGES/at-spi2-atk.mo
share/locale/nn/LC_MESSAGES/at-spi2-atk.mo
share/locale/pl/LC_MESSAGES/at-spi2-atk.mo
share/locale/pt/LC_MESSAGES/at-spi2-atk.mo
share/locale/pt_BR/LC_MESSAGES/at-spi2-atk.mo
share/locale/ro/LC_MESSAGES/at-spi2-atk.mo
share/locale/ru/LC_MESSAGES/at-spi2-atk.mo
share/locale/sk/LC_MESSAGES/at-spi2-atk.mo
share/locale/sl/LC_MESSAGES/at-spi2-atk.mo
share/locale/sr/LC_MESSAGES/at-spi2-atk.mo
share/locale/sr@latin/LC_MESSAGES/at-spi2-atk.mo
share/locale/sv/LC_MESSAGES/at-spi2-atk.mo
share/locale/ta/LC_MESSAGES/at-spi2-atk.mo
share/locale/th/LC_MESSAGES/at-spi2-atk.mo
share/locale/uk/LC_MESSAGES/at-spi2-atk.mo
share/locale/vi/LC_MESSAGES/at-spi2-atk.mo
share/locale/zh_CN/LC_MESSAGES/at-spi2-atk.mo
share/locale/zh_HK/LC_MESSAGES/at-spi2-atk.mo
share/locale/zh_TW/LC_MESSAGES/at-spi2-atk.mo
@dirrm lib/gtk-2.0/modules/at-spi-dbus/modules
@dirrm lib/gtk-2.0/modules/at-spi-dbus
@dirrm lib/gtk-3.0/modules/at-spi-dbus/modules
@dirrm lib/gtk-3.0/modules/at-spi-dbus
@dirrmtry lib/gtk-3.0/modules
@dirrmtry lib/gtk-3.0
@dirrmtry share/locale/zh_HK/LC_MESSAGES
@dirrmtry share/locale/zh_HK
@dirrmtry share/locale/sr@latin/LC_MESSAGES
@dirrmtry share/locale/sr@latin
@dirrmtry share/locale/en@shaw/LC_MESSAGES
@dirrmtry share/locale/en@shaw
@dirrmtry share/locale/ast/LC_MESSAGES
@dirrmtry share/locale/ast
include/at-spi2-atk/2.0/atk-bridge.h
lib/libatk-bridge-2.0.la
lib/libatk-bridge-2.0.so
lib/libatk-bridge-2.0.so.0
lib/gnome-settings-daemon-3.0/gtk-modules/at-spi2-atk.desktop
lib/gtk-2.0/modules/libatk-bridge.la
lib/gtk-2.0/modules/libatk-bridge.so
libdata/pkgconfig/atk-bridge-2.0.pc
@dirrmtry lib/gtk-2.0/modules
@dirrmtry lib/gtk-2.0
@dirrmtry lib/gnome-settings-daemon-3.0/gtk-modules
@dirrmtry lib/gnome-settings-daemon-3.0
@dirrm include/at-spi2-atk/2.0
@dirrm include/at-spi2-atk
# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/accessibility/at-spi2-core/Makefile,v 1.17 2010/11/16 11:48:22 kwm Exp $
# $MCom: ports/accessibility/at-spi2-core/Makefile,v 1.41 2012/12/16 22:36:25 kwm Exp $
PORTNAME= at-spi2-core
PORTVERSION= 0.4.1
PORTVERSION= 2.6.3
CATEGORIES= accessibility x11-toolkits
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= Assistive Technology Service Provider Interface
LICENSE= LGPL21
LIB_DEPENDS= dbus-glib-1:${PORTSDIR}/devel/dbus-glib
BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
USE_BZIP2= yes
PORTSCOUT= limitw:1,even
USE_XZ= yes
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gnomehack gnomehier intlhack
USE_XORG= x11 xi xtst
USE_GNOME= gnomehack gnomehier glib20 intlhack
USE_PKGCONFIG= build
USE_XORG= x11 xi xtst xext
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-static
CONFIGURE_ARGS= --enable-static \
--disable-xevie
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
......
SHA256 (gnome2/at-spi2-core-0.4.1.tar.bz2) = e3f10134851691b4c0878c2bdb778e21ded01e140b7a930d1958513c775765f9
SIZE (gnome2/at-spi2-core-0.4.1.tar.bz2) = 277204
SHA256 (gnome3/at-spi2-core-2.6.3.tar.xz) = fc4487ae46e847cfd057b329b852cf99923772ecd2ddc29f29670c9f2b15d0ea
SIZE (gnome3/at-spi2-core-2.6.3.tar.xz) = 445084
--- atspi/Makefile.in.orig 2011-01-24 00:11:24.000000000 +0000
+++ atspi/Makefile.in 2011-01-24 00:13:25.000000000 +0000
@@ -897,6 +897,7 @@
@HAVE_INTROSPECTION_TRUE@ --nsversion=2.0 \
@HAVE_INTROSPECTION_TRUE@ -I$(top_builddir) \
@HAVE_INTROSPECTION_TRUE@ -I$(top_srcdir) \
+@HAVE_INTROSPECTION_TRUE@ $(CPPFLAGS) \
@HAVE_INTROSPECTION_TRUE@ --include=GLib-2.0 \
@HAVE_INTROSPECTION_TRUE@ --include=GObject-2.0 \
@HAVE_INTROSPECTION_TRUE@ --libtool="$(top_builddir)/libtool" \
--- registryd/registry.c.orig 2011-06-20 23:41:30.000000000 +0200
+++ registryd/registry.c 2011-06-20 23:57:26.000000000 +0200
@@ -348,7 +348,7 @@
const char *member = dbus_message_get_member (message);
if (type != DBUS_MESSAGE_TYPE_SIGNAL)
- return;
+ return DBUS_HANDLER_RESULT_NOT_YET_HANDLED;
if (!g_strcmp0(iface, DBUS_INTERFACE_DBUS) &&
!g_strcmp0(member, "NameOwnerChanged"))
@@ -806,18 +806,18 @@
if (!dbus_message_get_args (message, NULL, DBUS_TYPE_STRING, &orig_name,
DBUS_TYPE_INVALID))
- return;
+ return NULL;
name = ensure_proper_format (orig_name);
evdata = (event_data *) g_malloc (sizeof (*evdata));
if (!evdata)
- return;
+ return NULL;
data = g_strsplit (name, ":", 3);
if (!data)
{
g_free (evdata);
- return;
+ return NULL;
}
if (!data [0])
data [1] = NULL;
@@ -856,7 +856,7 @@
if (!dbus_message_get_args (message, NULL, DBUS_TYPE_STRING, &orig_name,
DBUS_TYPE_INVALID))
- return;
+ return NULL;
name = ensure_proper_format (orig_name);
remove_events (registry, sender, name);
bin/at-spi-dbus-bus
etc/at-spi2/accessibility.conf
etc/xdg/autostart/at-spi-dbus-bus.desktop
include/at-spi-2.0/atspi/atspi.h
include/at-spi-2.0/atspi/atspi-accessible.h
include/at-spi-2.0/atspi/atspi-action.h
include/at-spi-2.0/atspi/atspi-application.h
include/at-spi-2.0/atspi/atspi-collection.h
include/at-spi-2.0/atspi/atspi-component.h
include/at-spi-2.0/atspi/atspi-constants.h
include/at-spi-2.0/atspi/atspi-device-listener.h
include/at-spi-2.0/atspi/atspi-device-listener-private.h
include/at-spi-2.0/atspi/atspi-document.h
include/at-spi-2.0/atspi/atspi-editabletext.h
include/at-spi-2.0/atspi/atspi-event-listener.h
include/at-spi-2.0/atspi/atspi-event-listener-private.h
include/at-spi-2.0/atspi/atspi-gmain.c
include/at-spi-2.0/atspi/atspi-gmain.h
include/at-spi-2.0/atspi/atspi-hyperlink.h
include/at-spi-2.0/atspi/atspi-hypertext.h
include/at-spi-2.0/atspi/atspi-image.h
include/at-spi-2.0/atspi/atspi-misc.h
include/at-spi-2.0/atspi/atspi-matchrule.h
include/at-spi-2.0/atspi/atspi-object.h
include/at-spi-2.0/atspi/atspi-private.h
include/at-spi-2.0/atspi/atspi-registry.h
include/at-spi-2.0/atspi/atspi-relation.h
include/at-spi-2.0/atspi/atspi-selection.h
include/at-spi-2.0/atspi/atspi-stateset.h
include/at-spi-2.0/atspi/atspi-table.h
include/at-spi-2.0/atspi/atspi-text.h
include/at-spi-2.0/atspi/atspi-types.h
include/at-spi-2.0/atspi/atspi-value.h
lib/girepository-1.0/Atspi-2.0.typelib
</