Commit 870062dc authored by bdrewery's avatar bdrewery
Browse files

For PYTHON_NO_DEPENDS don't pass PYTHON_VERSION to dependencies.

The PYTHON_NO_DEPENDS only really makes sense in meta ports, where passing
the PYTHON_VERSION doesn't make sense.  The ports listed will pick up
USES+=python and the default version as needed.

This fixes depending on both lang/python2 and lang/python3 in a meta package.
parent e0ef72cd
...@@ -372,7 +372,9 @@ IGNORE= needs an unsupported version of Python ...@@ -372,7 +372,9 @@ IGNORE= needs an unsupported version of Python
# try to find a different one, if the passed version fits into # try to find a different one, if the passed version fits into
# the supported version range. # the supported version range.
PYTHON_VERSION?= python${_PYTHON_VERSION} PYTHON_VERSION?= python${_PYTHON_VERSION}
.if !defined(PYTHON_NO_DEPENDS)
DEPENDS_ARGS+= PYTHON_VERSION=${PYTHON_VERSION} DEPENDS_ARGS+= PYTHON_VERSION=${PYTHON_VERSION}
.endif
# NOTE: # NOTE:
# #
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment