Commit 8c5dac56 authored by rene's avatar rene
Browse files

Unregister expired Python 3.5

parent b92bcc0d
......@@ -250,7 +250,7 @@ _INCLUDE_USES_PYTHON_MK= yes
# What Python version and what Python interpreters are currently supported?
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
_PYTHON_VERSIONS= 2.7 3.7 3.8 3.6 3.5 # preferred first
_PYTHON_VERSIONS= 2.7 3.7 3.8 3.6 # preferred first
_PYTHON_PORTBRANCH= 2.7 # ${_PYTHON_VERSIONS:[1]}
_PYTHON_BASECMD= ${LOCALBASE}/bin/python
_PYTHON_RELPORTDIR= lang/python
......@@ -329,7 +329,7 @@ DEV_WARNING+= "lang/python27 reached End of Life and will be removed on 2020-12
.elif ${_PYTHON_ARGS} == 2
DEV_ERROR+= "USES=python:2 is no longer supported, use USES=python:2.7"
.elif ${_PYTHON_ARGS} == 3
DEV_ERROR+= "USES=python:3 is no longer supported, use USES=python:3.5+ or an appropriate version range"
DEV_ERROR+= "USES=python:3 is no longer supported, use USES=python:3.6+ or an appropriate version range"
.endif # ${_PYTHON_ARGS} == 2.7
_PYTHON_VERSION:= ${PYTHON_DEFAULT}
......@@ -428,7 +428,7 @@ PKGNAMESUFFIX= ${PYTHON_PKGNAMESUFFIX}
# To avoid having dependencies with @ and empty flavor:
# _PYTHON_VERSION is either set by (first that matches):
# - If using Python flavors, from the current Python flavor
# - If using a version restriction (USES=python:3.5+), from the first
# - If using a version restriction (USES=python:3.6+), from the first
# acceptable default Python version.
# - From PYTHON_DEFAULT
PY_FLAVOR= py${_PYTHON_VERSION:S/.//}
......@@ -458,7 +458,7 @@ PYTHON_CMD?= ${_PYTHON_BASECMD}${_PYTHON_VERSION}
.if exists(${PYTHON_CMD}-config)
PYTHON_ABIVER!= ${PYTHON_CMD}-config --abiflags
.elif ${PYTHON_REL} < 3800
# Default ABI flags for lang/python3[567] ports
# Default ABI flags for lang/python3[67] ports
PYTHON_ABIVER= m
.endif
.endif
......
......@@ -90,11 +90,11 @@ PERL5_DEFAULT:= ${_PERL5_FROM_BIN:R}
PGSQL_DEFAULT?= 11
# Possible values: 7.2, 7.3, 7.4
PHP_DEFAULT?= 7.4
# Possible values: 2.7, 3.5, 3.6, 3.7, 3.8
# Possible values: 2.7, 3.6, 3.7, 3.8
PYTHON_DEFAULT?= 3.7
# Possible values: 2.7
PYTHON2_DEFAULT?= 2.7
# Possible values: 3.5, 3.6, 3.7, 3.8
# Possible values: 3.6, 3.7, 3.8
PYTHON3_DEFAULT?= 3.7
# Possible values: 2.5, 2.6, 2.7
RUBY_DEFAULT?= 2.6
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment