Commit a637a246 authored by antoine's avatar antoine
Browse files

Drop python 2.7 support from a few ports

With hat:	portmgr
parent 30151437
......@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= liblo.so:audio/liblo
USES= localbase python
USES= localbase python:3.6+
USE_PYTHON= autoplist concurrent cython distutils
post-install:
......
......@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libmad.so:audio/libmad
USES= python
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
do-configure:
......
......@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PYNUMPY}
LIB_DEPENDS= libsndfile.so:audio/libsndfile
RUN_DEPENDS= ${PYNUMPY}
USES= python localbase
USES= python:3.6+ localbase
USE_PYTHON= distutils autoplist cython
.include <bsd.port.mk>
......@@ -18,7 +18,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=0.14.0:www/py-requests@${PY_FLAVOR
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>=1.1.2:devel/py-nose@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}fudge>=1.0.3:devel/py-fudge@${PY_FLAVOR}
USES= python
USES= python:3.6+
USE_PYTHON= autoplist distutils
PORTDOCS= README.rst
......
......@@ -17,7 +17,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cffi>=1.0.0:devel/py-cffi@${PY_FLAVOR} \
${PYNUMPY} \
portaudio>0:audio/portaudio
USES= python
USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
......
......@@ -24,7 +24,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mutagen>=1.31.0:audio/py-mutagen@${PY_FLAVOR
${PYTHON_PKGNAMEPREFIX}wheel>=0.24.0:devel/py-wheel@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=2.9.0:www/py-requests@${PY_FLAVOR}
USES= python
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
USE_GITHUB= yes
......
......@@ -19,7 +19,7 @@ RUN_DEPENDS= flac:audio/flac \
${PYTHON_PKGNAMEPREFIX}pyaudio>0:audio/py-pyaudio@${PY_FLAVOR}
NO_ARCH= yes
USES= python
USES= python:3.6+
USE_PYTHON= distutils autoplist
post-extract:
......
......@@ -16,7 +16,7 @@ LICENSE= MIT
LIB_DEPENDS= ${PY_BOOST} \
libtag.so:audio/taglib
USES= compiler:c++11-lang python shebangfix
USES= compiler:c++11-lang python:3.6+ shebangfix
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= configure.py
CONFIGURE_ARGS= --taglib-inc-dir="${LOCALBASE}/include/taglib" \
......
......@@ -14,7 +14,7 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= ${PYNUMPY}
USES= python
USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
......
......@@ -13,7 +13,7 @@ COMMENT= Interface to the Google WebRTC Voice Activity Detector (VAD)
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
USES= compiler:c11 python
USES= compiler:c11 python:3.6+
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
......@@ -21,7 +21,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}Flask>=0.10.1:www/py-flask@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.10.0:devel/py-six@${PY_FLAVOR}
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${PY_FLAVOR}
USES= python
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
......
......@@ -13,7 +13,7 @@ LICENSE= BSD2CLAUSE
RUN_DEPENDS= iperf3>=0:benchmarks/iperf3
USES= python
USES= python:3.6+
USE_PYTHON= autoplist distutils
NO_ARCH= yes
......
......@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests>=2.6.0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}slumber>=0.7.1:www/py-slumber@${PY_FLAVOR}
USES= python
USES= python:3.6+
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
......@@ -18,7 +18,7 @@ PY_DEPENDS= ${PYNUMPY} \
BUILD_DEPENDS= ${PY_DEPENDS}
RUN_DEPENDS= ${PY_DEPENDS}
USES= compiler python
USES= compiler python:3.6+
USE_GITHUB= yes
GH_ACCOUNT= bxlab
USE_PYTHON= autoplist cython distutils
......
......@@ -14,7 +14,7 @@ LICENSE= APACHE20
RUN_DEPENDS= ${PYNUMPY} \
${PYTHON_PKGNAMEPREFIX}pandas>=0.15:math/py-pandas@${PY_FLAVOR}
USES= python
USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
......
......@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.txt
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pandas>0:math/py-pandas@${PY_FLAVOR}
USES= python
USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
......
......@@ -13,7 +13,7 @@ LICENSE= BSD3CLAUSE
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR}
USES= python
USES= python:3.6+
USE_PYTHON= distutils concurrent autoplist
NO_ARCH= yes
......
......@@ -12,7 +12,7 @@ COMMENT= Python module for reading, manipulating and writing genomic data sets
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
USES= gmake python
USES= gmake python:3.6+
USE_PYTHON= autoplist distutils cython cython_run
.include <bsd.port.mk>
......@@ -11,7 +11,7 @@ COMMENT= API for Xena Hub to access genetic information shared through the hub
LICENSE= APACHE20
USES= python
USES= python:3.6+
USE_PYTHON= distutils autoplist
NO_ARCH= yes
......
......@@ -16,7 +16,7 @@ LICENSE= MIT
BUILD_DEPENDS= ${PYNUMPY}
RUN_DEPENDS:= ${BUILD_DEPENDS}
USES= python
USES= python:3.6+
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment