Commit a74f5276 authored by sunpoet's avatar sunpoet
Browse files

Change RUN_DEPENDS from rubygem-pdf-core to rubygem-pdf-core07

- Update version requirement of RUN_DEPENDS
- Bump PORTREVISION for dependency change

It should fix the resulting FDP pdf file.

PR:		253178
parent f0034232
......@@ -3,7 +3,7 @@
PORTNAME= prawn
PORTVERSION= 2.2.2
PORTREVISION= 1
PORTREVISION= 2
CATEGORIES= print rubygems
MASTER_SITES= RG
......@@ -16,11 +16,12 @@ LICENSE_FILE_GPLv2= ${WRKSRC}/GPLv2
LICENSE_FILE_GPLv3= ${WRKSRC}/GPLv3
LICENSE_FILE_RUBY= ${WRKSRC}/LICENSE
RUN_DEPENDS= rubygem-pdf-core>=0.7.0:print/rubygem-pdf-core \
rubygem-ttfunk>=1.5:print/rubygem-ttfunk
RUN_DEPENDS= rubygem-pdf-core07>=0.7.0<0.8:print/rubygem-pdf-core07 \
rubygem-ttfunk>=1.5<2:print/rubygem-ttfunk
NO_ARCH= yes
USE_RUBY= yes
USES= gem
USE_RUBY= yes
NO_ARCH= yes
.include <bsd.port.mk>
--- prawn.gemspec.orig 2018-04-28 17:42:14 UTC
+++ prawn.gemspec
@@ -24,7 +24,7 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<ttfunk>.freeze, ["~> 1.5"])
- s.add_runtime_dependency(%q<pdf-core>.freeze, ["~> 0.7.0"])
+ s.add_runtime_dependency(%q<pdf-core>.freeze, ["~> 0.7"])
s.add_development_dependency(%q<pdf-inspector>.freeze, [">= 1.2.1", "< 2.0.a"])
s.add_development_dependency(%q<yard>.freeze, [">= 0"])
s.add_development_dependency(%q<rspec>.freeze, ["~> 3.0"])
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment