Commit aedc12ff authored by mat's avatar mat
Browse files

Try to be more helpful to our users, and keep all the possible versions

close to their default value in Mk/bsd.default-versions.mk.

Sponsored by:	Absolight
parent fe51d1cc
......@@ -15,6 +15,8 @@ FIREBIRD_VER= ${firebird_ARGS}
FIREBIRD_VER?= ${FIREBIRD_DEFAULT:S/.//}
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
.if ${FIREBIRD_VER} == 25
LIB_DEPENDS+= libfbclient.so:databases/firebird25-client
.else
......
......@@ -28,6 +28,8 @@
_INCLUDE_USES_GHOSTSCRIPT_MK= yes
# allowed versions
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
_GS_VERSION= 7 8 9 agpl
_GS_ARGS= ${ghostscript_ARGS}
......
......@@ -10,6 +10,8 @@
.if !defined(_INCLUDE_USES_LUA_MK)
_INCLUDE_USES_LUA_MK= yes
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
_LUA_VALID_VERSIONS= 53 52 51
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
......
......@@ -49,6 +49,8 @@ PERL5_DEPEND= ${PERL5}
THIS_IS_OLD_PERL= yes
.else
# end of remove
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
.if ${PERL5_DEFAULT} == 5.18
.include "${PORTSDIR}/lang/perl5.18/version.mk"
......@@ -88,6 +90,8 @@ PERL_ARCH?= mach
# there must always be a default to prevent dependency failures such
# as "ports/lang: not found". Also, perl5-devel is taken care in the
# perl5_default file, or up there in the default versions selection.
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
.if ${PERL_LEVEL} >= 502200
PERL_PORT?= perl5.22
.elif ${PERL_LEVEL} >= 502000
......
......@@ -31,6 +31,8 @@ _INCLUDE_USES_PGSQL_MK= yes
# to add dependencies; use WANT_PGSQL as explained above
#
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
VALID_PGSQL_VER= 9.0 9.1 9.2 9.3 9.4 9.5
# Override non-default LIBVERS like this:
......
......@@ -220,6 +220,8 @@
_INCLUDE_USES_PYTHON_MK= yes
# What Python version and what Python interpreters are currently supported?
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
_PYTHON_VERSIONS= 2.7 3.4 3.5 3.3 # preferred first
_PYTHON_PORTBRANCH= 2.7 # ${_PYTHON_VERSIONS:[1]}
_PYTHON_BASECMD= ${LOCALBASE}/bin/python
......
......@@ -67,6 +67,8 @@ _INCLUDE_USES_TCL_MK= yes
#
# List the currently available versions.
#
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
_TCLTK_VALID_VERSIONS= 84 85 86
#
......
......@@ -92,6 +92,8 @@ WARNING+= "DEFAULT_APACHE_VER is defined, consider using DEFAULT_VERSIONS+=apach
.endif
DEFAULT_APACHE_VERSION?= ${APACHE_DEFAULT:S/.//}
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
APACHE_SUPPORTED_VERSION= 24 22 # preferred version first
# Print warnings
......
......@@ -100,6 +100,8 @@ WARNING+= "DEFAULT_MYSQL_VER is defined, consider using DEFAULT_VERSIONS=mysql=$
.if defined(USE_MYSQL)
DEFAULT_MYSQL_VER?= ${MYSQL_DEFAULT:S/.//}
# MySQL client version currently supported.
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
MYSQL51_LIBVER= 16
MYSQL55_LIBVER= 18
MYSQL55m_LIBVER= 18
......
......@@ -18,13 +18,21 @@ _l= ${lang:C/=.*//g}
${_l:tu}_DEFAULT= ${lang:C/.*=//g}
.endfor
# Possible values: 2.2, 2.4
APACHE_DEFAULT?= 2.4
# Possible values: 2.5
FIREBIRD_DEFAULT?= 2.5
# Possible values: 3.0.0
FPC_DEFAULT?= 3.0.0
# Possible values: 4.6, 4.7, 4.8, 4.9, 5
GCC_DEFAULT?= 4.8
# Possible values: 7, 8, 9, agpl
GHOSTSCRIPT_DEFAULT?= agpl
# Possible values: 5.1, 5.2, 5.3
LUA_DEFAULT?= 5.2
# Possible values: 5.1, 5.5, 5.6, 5.7, 5.5m, 10.0m, 10.1m, 5.5p, 5.6p
MYSQL_DEFAULT?= 5.6
# Possible values: 5.18, 5.20, 5.22, devel
.if !exists(${LOCALBASE}/bin/perl) || (!defined(_PORTS_ENV_CHECK) && \
defined(PACKAGE_BUILDING))
PERL5_DEFAULT?= 5.20
......@@ -39,12 +47,19 @@ _PERL5_FROM_BIN!= perl -e 'printf "%vd\n", $$^V;'
_EXPORTED_VARS+= _PERL5_FROM_BIN
PERL5_DEFAULT:= ${_PERL5_FROM_BIN:R}
.endif
# Possible values: 9.0, 9.1, 9.2, 9.3, 9.4, 9.5
PGSQL_DEFAULT?= 9.3
# Possible values: 5.5, 5.6, 7.0
PHP_DEFAULT?= 5.6
# Possible values: 2.7, 3.3, 3.4, 3.5
PYTHON_DEFAULT?= 2.7
# Possible values: 2.7
PYTHON2_DEFAULT?= 2.7
# Possible values: 3.3, 3.4, 3.5
PYTHON3_DEFAULT?= 3.4
# Possible values: 2.0, 2.1, 2.2, 2.3
RUBY_DEFAULT?= 2.2
# Possible values: 8.4, 8.5, 8.6
TCLTK_DEFAULT?= 8.6
# Version of lang/gcc. Do not override!
......
......@@ -40,6 +40,8 @@ FPC_Include_MAINTAINER= freebsd-fpc@FreeBSD.org
FPC_Pre_Include= bsd.fpc.mk
DEFAULT_FPC_VER= ${FPC_DEFAULT}
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
FPC_VER= ${DEFAULT_FPC_VER}
FPC_ARCH= ${ARCH:S/amd64/x86_64/}
......
......@@ -35,6 +35,8 @@ GCC_Include_MAINTAINER= gerald@FreeBSD.org
# All GCC versions supported by the ports framework. Keep them in
# ascending order and in sync with the table below.
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
GCCVERSIONS= 040200 040600 040700 040800 040900 050000
# The first field is the OSVERSION in which it disappeared from the base.
......
......@@ -55,6 +55,8 @@ PHP_EXT_DIR!= ${PHPBASE}/bin/php-config --extension-dir | ${SED} -ne 's,^${PHPBA
.else
DEFAULT_PHP_VER?= ${PHP_DEFAULT:S/.//}
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
PHP_VER?= ${DEFAULT_PHP_VER}
.if ${PHP_VER} == 70
PHP_EXT_DIR= 20151012
......
......@@ -167,6 +167,8 @@ _RUBY_VENDORDIR!= ${_RUBY_CONFIG} 'puts C["vendordir"]'
RUBY?= ${LOCALBASE}/bin/${RUBY_NAME}
.if defined(RUBY_VER)
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
. if ${RUBY_VER} == 2.0
#
# Ruby 2.0
......@@ -207,6 +209,8 @@ RUBY_PORTEPOCH= 1
RUBY_PATCHLEVEL= 0
RUBY23= "" # PLIST_SUB helpers
# When adding a version, please keep the comment in
# Mk/bsd.default-versions.mk in sync.
. else
#
# Other versions
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment