Commit d0afde82 authored by sunpoet's avatar sunpoet
Browse files

Add py-requirementslib 1.5.16

RequirementsLib provides a simple layer for building and interacting with
requirements in both the Pipfile format and the requirements.txt format. This
library was originally built for converting between these formats in Pipenv.

WWW: https://github.com/sarugaku/requirementslib
parent 3a8ee803
......@@ -5023,6 +5023,7 @@
SUBDIR += py-repoze.xmliter
SUBDIR += py-represent
SUBDIR += py-requestsexceptions
SUBDIR += py-requirementslib
SUBDIR += py-resolver
SUBDIR += py-resource
SUBDIR += py-responses
......
# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
# $FreeBSD$
PORTNAME= requirementslib
PORTVERSION= 1.5.16
CATEGORIES= devel python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Tool for converting between pip-style and pipfile requirements
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}invoke>=0:devel/py-invoke@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}parver>=0:devel/py-parver@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}vistir>=0.3.1:devel/py-vistir@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}wheel>=0.33.0:devel/py-wheel@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}appdirs>=0:devel/py-appdirs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}attrs>=19.2:devel/py-attrs@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}cached-property>=0:devel/py-cached-property@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}dateutil>=0:devel/py-dateutil@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}distlib>=0.2.8:devel/py-distlib@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}orderedmultidict>=0:devel/py-orderedmultidict@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}packaging>=19.0:devel/py-packaging@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pep517>=0.5.0:devel/py-pep517@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pip-shims>=0.5.2:devel/py-pip-shims@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}plette>=0:devel/py-plette@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}requests>=0:www/py-requests@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}six>=1.11.0:devel/py-six@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}tomlkit>=0.5.3:textproc/py-tomlkit@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}vistir>=0.3.1:devel/py-vistir@${PY_FLAVOR}
USES= python:3.6+
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
.include <bsd.port.mk>
TIMESTAMP = 1613478303
SHA256 (requirementslib-1.5.16.tar.gz) = 9c1e8666ca4512724cdd1739adcc7df19ec7ad2ed21f0e748f9631ad6b54f321
SIZE (requirementslib-1.5.16.tar.gz) = 118300
RequirementsLib provides a simple layer for building and interacting with
requirements in both the Pipfile format and the requirements.txt format. This
library was originally built for converting between these formats in Pipenv.
WWW: https://github.com/sarugaku/requirementslib
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment