1. 21 Sep, 2020 2 commits
  2. 19 Sep, 2020 1 commit
  3. 08 Sep, 2020 1 commit
  4. 06 Sep, 2020 1 commit
  5. 01 Sep, 2020 1 commit
  6. 24 Jul, 2020 1 commit
  7. 09 Jul, 2020 1 commit
    • sunpoet's avatar
      Update PYNUMPY · 1202d2eb
      sunpoet authored
      science/py-geometer requires math/py-numpy between 1.15 and 1.20 (>=1.15,<1.20)
      1202d2eb
  8. 11 May, 2020 1 commit
    • dbaio's avatar
      Update Sphinx · 36c42ca3
      dbaio authored
      - Repocopy textproc/py-sphinx to textproc/py-sphinx18
      
        Update it to 1.8.5 (latest version from 1.8.X).
        This version supports Python 2 and 3.
        Add test target.
      
      - textproc/py-sphinx: Update to 3.0.2
      
        Python 3 only (3.5+).
        Add test target.
      
      - Mk/Uses/python.mk: Add PY_SPHINX
      
        Shared macro to use with flavors and not break
        ports with USES=python (all versions).
      
        Python >=3.5  --> textproc/py-sphinx (v3.0.2)
        Python < 3.5  --> textproc/py-sphinx18 (v1.8.5)
      
        All ports that uses sphinx were changed to use the new variable
        ${PY_SPHINX} in the dependency line, exceptions:
      
          * Ports that fails to build with sphinx 3.0.2 because of code.
            They are pointing to textproc/py-sphinx18 directly.
            There aren't many ports.
      
          * Ports that doesn't know Python flavors.
      
      - Add several patches to fix Sphinx consumers
      
        The most common issues are related with pkg-plist, the output
        files from Sphinx changes between versions, keep this dynamically
        is the better approach.
      
        This will save time in future sphinx updates.
      
      PR:		245629
      Exp-run by:	antoine
      36c42ca3
  9. 06 May, 2020 1 commit
  10. 02 May, 2020 1 commit
    • sunpoet's avatar
      Update PY_TYPING · f7476547
      sunpoet authored
      devel/py-tenacity requires devel/py-typing 3.7.4.1
      f7476547
  11. 21 Apr, 2020 1 commit
    • sunpoet's avatar
      Update PYNUMPY · f6a8da88
      sunpoet authored
      astro/py-metpy requires math/py-numpy 1.16.0
      f6a8da88
  12. 01 Apr, 2020 1 commit
  13. 31 Mar, 2020 1 commit
    • sunpoet's avatar
      Update PY_ENUM34 · c06a062c
      sunpoet authored
      devel/py-clikit requires devel/py-enum34 between 1.1 and 2.0 (>=1.1,<2.0)
      c06a062c
  14. 24 Mar, 2020 1 commit
  15. 23 Feb, 2020 1 commit
  16. 04 Feb, 2020 1 commit
    • sunpoet's avatar
      Update PYNUMPY · dbaf893a
      sunpoet authored
      science/py-geometer requires math/py-numpy between 1.15 and 1.19 (>=1.15,<1.19)
      dbaf893a
  17. 02 Feb, 2020 1 commit
    • sunpoet's avatar
      Update PYNUMPY · 3aa2668b
      sunpoet authored
      devel/py-xarray requires math/py-numpy 1.15
      3aa2668b
  18. 31 Jan, 2020 1 commit
    • sunpoet's avatar
      Update PY_ENUM34 · 5be3725c
      sunpoet authored
      devel/py-glance-store requires devel/py-enum34 1.0.4.
      5be3725c
  19. 15 Jan, 2020 1 commit
  20. 13 Jan, 2020 1 commit
  21. 09 Jan, 2020 2 commits
  22. 16 Dec, 2019 1 commit
  23. 06 Nov, 2019 1 commit
  24. 02 Nov, 2019 1 commit
  25. 04 Aug, 2019 1 commit
    • sunpoet's avatar
      Update PY_TYPING · 412da47d
      sunpoet authored
      devel/py-typing-extensions requires py-typing 3.7.4+.
      412da47d
  26. 03 Jul, 2019 2 commits
    • koobs's avatar
      Uses/python.mk: Clarify language, messaging and usage for <version-spec> · d6e2ebce
      koobs authored
      Make it clear that <version-spec> is a declarative not imperative
      specification to declare what version of Python a port or software
      *supports*, not the versions it should *use*.
      
      The version that gets selected is a function of Python.mk, DEFAULT_VERSIONS
      which change over time, and can be overridden or otherwise set by the user.
      
      While I'm here, add a special note about bare USES=python (without a
      <version-spec>), which is likely to be deprecated at some point down the
      line. In the meantime, describe what the semantics of not specifying a
      <version-spec> entails, and encourage minimisation of its use where
      appropriate.
      
      Approved by:	koobs (python, maintainer)
      d6e2ebce
    • wen's avatar
      399eec42
  27. 23 Jun, 2019 1 commit
  28. 31 May, 2019 1 commit
  29. 27 Apr, 2019 1 commit
  30. 25 Apr, 2019 1 commit
  31. 18 Apr, 2019 1 commit
  32. 16 Jan, 2019 1 commit
  33. 18 Dec, 2018 1 commit
  34. 25 Nov, 2018 1 commit
  35. 03 Nov, 2018 1 commit
  36. 06 Jul, 2018 1 commit
  37. 18 Apr, 2018 1 commit